Practical 1										Date:

Aim: To Study about Microwind tool and λ (Lambda) Rules for Layout Generation.

Objective: 
1. To be familiar with tool.
2. To learn about λ (Lambda) Rules for 90 nm Technology.

Microwind Getting Started:

The present experiment is a guide to using the « Microwind » educational software on a PC computer. 
The MICROWIND program allows the student to design and simulate an integrated circuit. The package itself contains a library of common logic and analog ICs to view and simulate. MICROWIND includes all the commands for a mask editor as well as new original tools never gathered before in a single module. You can gain access to Circuit Simulation by pressing one single key. The electric extraction of your circuit is automatically performed and the analog simulator produces voltage and current curves immediately. 
A specific command displays the characteristics of pMOS and nMOS, where the size of the device and the process parameters can be very easily changed. Altering the MOS model parameters and, then, seeing the effects on the Vds and Ids curves constitutes a good interactive tutorial on devices. 
The Process Simulator shows the layout in a vertical perspective, as when fabrication has been completed. This feature is a significant aid to supplement the descriptions of fabrication found in most textbooks. 
The Logic Cell Compiler is a particularly sophisticated tool enabling the automatic design of a CMOS circuit corresponding to your logic description in VERILOG. The DSCH software, which is a user-friendly schematic editor and a logic simulator presented in a companion manual, is used to generate this Verilog description. The cell is created in compliance with the environment, design rules and fabrication specifications. 
A set of CMOS processes ranging from 1.2µm down to state-of-the-art 0.25µm are proposed.
To use the MICROWIND program use the following procedure: 
		Go to the directory in which the software has been copied
		(The default directory is MICROWIND)
		Double-click on the MicroWind icon 
The MICROWIND display window is shown in Figure 1. It includes four main windows: the main menu, the layout display window, the icon menu and the layer palette. The cursor appears in the middle of the layout window and is controlled by using the mouse. 
The layout window features a grid that represents the current scale of the drawing, scaled in lambda  () units and in micron. 
The lambda unit is fixed to half of the minimum available lithography of the technology. The default technology is a 0.8 µm technology, consequently lambda is 0.4 µm. 
[image: ]
Fig. 1. The MICROWIND window as it appears at the  initialization stage..
The MOS device
The MOS symbols are reported below. The n-channel MOS is built using polysilicon as the gate material and N+ diffusion to build the source and drain. The p-channel MOS is built using polysilicon as the gate material and P+ diffusion to build the source and drain. 


Manual Design

			
By using the following procedure, you can create a manual design of the n-channel MOS. The default icon is the drawing icon shown above. It permits box editing. The display window is empty. The palette is located in the lower right corner of the screen. A red color indicates the current layer. Initially the selected layer in the palette is polysilicon. The two first steps are illustrated in Figure 2. 
	Fix the first corner of the box with the mouse.
 	While keeping the mouse button pressed, move the mouse to the 
opposite corner of the box.
	Release the button. This creates a box in polysilicon layer as shown in Figure 2.
	The box width should not be inferior to 2 , which is the minimum width of the
	polysilicon box.


Fig. 2. Creating a polysilicon box.

Change the current layer into N+ diffusion by a click on the palette of the Diffusion N+ button. Make sure that the red layer is now the N+ Diffusion. Draw a n-diffusion box at the bottom of the drawing as in Figure 3. N-diffusion boxes are represented in green. The intersection between diffusion and polysilicon creates the channel of the nMOS device.


 
Fig. 3. Creating the N-channel MOS transistor

Process Simulation


Click on this icon to access process simulation. The cross-section is given by a click of the mouse at the first point and the release of the mouse at the second point. In the example below (Figure 4), three nodes appear in the cross-section of the n-channel MOS device: the gate (red), the left diffusion called source (green) and the right diffusion called drain (green), over a substrate (gray). The gate is isolated by a thin oxide called the gate oxide. Various steps of oxidation have lead to a thick oxide on the top of the gate. 

 
Fig. 4. The cross-section of the nMOS devices.

The physical properties of the source and of the drain are exactly the same. Theoretically, the source is the origin of channel impurities. In the case of this nMOS device, the channel impurities are the electrons. Therefore, the source is the diffusion area with the lowest voltage. 

The polysilicon gate floats over the channel, and splits the diffusion into 2 zones, the source and the drain. The gate controls the current flow from the drain to the source, both ways. A high voltage on the gate attracts electrons below the gate, creates an electron channel and enables current to flow. A low voltage disables the channel.



Mos Characteristics


Click on the MOS characteristics icon. The screen shown in Figure 5 appears. It represents the Id/Vd simulation of the nMOS device. 



Fig. 5. N-Channel MOS characteristics.
The MOS size (width and length of the channel situated at the intersection of the polysilicon gate and the diffusion) has a strong influence on the value of the current. In Figure 5, the MOS width is 12.8µm and the length is 1.2µm. Click on OK to return to the editor. A high gate voltage (Vg =5.0) corresponds to the highest Id/Vd curve. For Vg=0, no current flows. The maximum current is obtained for Vg=5.0V, Vd=5.0V, with Vs=0.0.
The MOS parameters correspond to SPICE Level 3. You can alter the value of the parameters, or even access to Level 1. You may also skip to PMOS. You may as well add some measurements to fit the simulation. Finally, you can simulate devices with other sizes in the proposed list.

Add Properties for Simulation
Properties must be added to the layout to activate the MOS device. The most convenient way to operate the MOS is to apply a clock to the gate, another to the source and to observe the drain. The summary of available properties is reported below.




	Apply a clock to the drain. Click on the Clock icon, click on the left diffusion. The Clock menu appears (See below). Change the name into « drain » and click on OK. A default clock with 3 ns period is generated. The Clock property is sent to the node and appears at the right hand side of the desired location with the name « drain ».
  


Fig. 6. The clock menu.

	Apply a clock to the gate. Click on the Clock icon and then, click on 
the polysilicon gate. The clock menu appears again. 
Change the name into « gate» and click on OK to apply a clock with 6 ns period.
	Watch the output: Click on the Visible icon and then, click on the right diffusion.
	The window below appears. Click OK. The Visible property is then sent 
to the node. The associated text « s1 » is in italic. The wave form of this node 
will appear at the next simulation.



Fig. 7. The visible node  menu.
Save before Simulation
Click on File in the main menu. Move the cursor to Save as ... and click on it. A new window appears, into which you enter the design name. Type, for example, myMos. Use the keyboard for this and press . Then click on OK. After a confirmation question, the design is saved under that filename. 

	IMPORTANT : Always save BEFORE any simulation !

Analog Simulation 
   
Click on Simulate on the main menu. The timing diagrams of the inverter appear, as shown in Figure 8. 




Fig. 8. Analog simulation of the MOS device.
When the gate is at zero, no channel exists so the node s1 is disconnected from the drain. When the gate is on, the source copies the drain. It can be observed that the nMOS device drives well at zero but at the high voltage. The final value is 4.2V, that is VDD minus the threshold voltage. Click on More in order to perform more simulations. Click on Stop to return to the editor.






λ (Lambda) Rule:

Design Rules

The software can handle various technologies. The process parameters are stored in files with the appendix '.RUL'. The default technology corresponds to the ATMEL-ES2 2-metal 0.8µm CMOS process. The default file is ES208.RUL. 

To select a foundry, click on File -> Select Foundry and choose the appropriate technology in the list.

N-Well





r101	Minimum well size : 12 
r102  	Between wells : 12 

Diffusion

r201	Minimum diffusion size : 4 
r202	Between two  diffusions : 4 
r203	Extra well after diffusion : 6 
r204  	Between diffusion and well : 6 






 Polysilicon

r301	Polysilicon  width : 2 
r302	Polysilicon gate on diff n+ : 2  
r303	Polysilicon gate on diff p+ : 2   
r304	Between two polysilicons : 3 
r305	Poly v.s other diff diffusion : 2 
r306	Diffusion after polysilicon : 4 
r307	Extension of Poly after diff : 3 



Contact

r401	Contact width : 2 
r402	Between two contacts : 3  
r403	Extra metal over contact:1 
r404	Extra poly over contact: 2 
r405	Extra diff over contact: 1 




Metal 1

r501	Metal width  : 3 
r502	Between two metals : 3 
	


Via

r601	Via width : 3 
r602	Between two Via: 3 
r603	Between Via and contact: 3 
r604	Extra metal over via: 2 
r605	Extra metal 2 over via: 2 






Metal 2

r701	Metal width: 5 
r702	Between two metal2 : 5 





Via 2

r801	Via2 width : 3 
r802	Between two Via2s: 4 
r803	Between Via2 and via : 4 
r804	Extra metal2 & metal 3 over via2: 3 

Metal 3

r901	Metal3 width: 6 
r902	Between two metal3s : 5 


Via 3

ra01	Via3 width : 4 
ra02	Between two Via3s : 6 
ra03	Between Via3 and via2 : 6 
ra04	Extra metal4 and metal3 over via3: 6 

Metal 4

rb01	Metal4 width: 10 
rb02	Between two metal4s: 22 


Via 4

rc01	Via4  width : 4 
rc02	Between two Via4s : 6 
rc03	Between Via4 and Via3 : 6 
rc04	Extra metal4 & metal 5 over via4: 6 


Metal 5

rd01 	Metal 5 width: 10 
rd02	Between two metal5s : 4 




Pads

rp01 	Pad width: 100 µm (lambda conversion depending on the technology)
rp02 	Between two pads 100 µm
rp03 	Opening in passivation v.s via : 5µm
rp04 	Opening in passivation v.s metals: 5µm
rp05	Between pad and unrelated active area : 20 µm





Conclusion:




Practical 2										Date:

Aim: To generate layout for CMOS Inverter circuit and simulate it for verification..

Objective: 
1. To simulate CMOS inverter and obtain VTC
2. To Prepare the Layout of Horizontal Inverter.
3. Measure propagation delay. 

Theory: The inverter circuit uses two MOS devices which are enhancement type. Q1 acts as the load resistor and Q2 as driver device. The load is PMOS and driver is NMOS. The input is connected to gate terminal of both MOS device. The source of PMOS is connected to supply Vdd and drain terminal to drain of NMOS from which output is taken.

Layout of Inverter

1. Vertical Layout Design:



Results:




























Observation:

Delay:

Optimized Area:












2. Horizontal Layout Design:






















Result:






















3. Inverter with Dual Contact and Substrate:





















Result:























VTC Characteristic:
This represents Output Voltage Vs. Input Voltage Graph.

































Conclusion:


Practical 3										Date:

Aim: To prepare layout for given logic function and verify it with simulations.

Objective: 
1. To Simulate the Buffer.
2. To Simulate NAND and NOR Gate.
3. To Simulate one Boolean Equation.

Layout of Buffer:









Results:

Layout of CMOS NAND Gate:



















Results:

























Layout of CMOS NOR Gate:



















Results:
























Layout of B:oolean Function:




















Results:
















Conclusion:

	


Practical 4										Date:

Aim: To study about VHDL as first Look.

Objective: 
1. To learn Basic about VHDL.
2. To know about VHDL Elements.

Introduction:
· VHDL stands for Very high speed  integrated circuit Hardware Description Language
· Funded by the US Department of Defense in the 70's and 80's
· Originally meant for design standardisation, documentation, simulation and ease of maintenance.
· Established as IEEE standard IEEE 1076 in 1987. An updated standard, IEEE 1164 was adopted in 1993. In 1996 IEEE 1076.3 became a VHDL synthesis standard.
· Today VHDL is widely used across the industry for design description, simulation and synthesis. 
[bookmark: _Toc494603454]Software Language Vs Hardware Description Language
In a software language, all assignments are sequential. This means that the order in which the statements appear is significant because they are executed that way. On the other hand the events in hardware are concurrent, and they must be represented that way. A software language cannot be used to describe hardware and therefore a Hardware Description Language is required. To illustrate this fact consider the following circuit:

The required output equation is C =  (not (X) and Y) or (not (X))

[image: ]


If the statements are evaluated sequentially like software, we get different results when the order is changed. This is because of the fact that hardware is always concurrent. Hence software languages and tools cannot be used to describe hardware. In VHDL language "concurrent statements" are defined to take care of concurrency in hardware. The simulation engine (that runs on sequential computers) also has to ensure concurrency in the simulation results.

[bookmark: _Toc494603455]
How is concurrency achieved?
One of the requirements for the simulation engine is "order independence" for all concurrent statements. Thus, if a signal is inverted by process "A", and that signal is read by process "B" at the same instant of time, it is imperative that process "B" read the old uninverted value. This is regardless of whether process "A" or process "B" was executed first. This is achieved means of scheduling. When the simulator tags the signal for an update, it does not perform the update immediately, but rather remembers the value to be updated. The value is actually updated when the simulator has finished processing the complete description once.  

Features of VHDL:
· VHDL is the combination of following languages
	- Sequential Language
	- Concurrent Language
	- Net-List Language
	- Simulation Language
	- Timing Specifications
	- Test Language
·  Powerful Language Constructs
	- e.g. if –then –else / when –else etc.
·  Design Hierarchies to create modular design
· Support for Design Libraries
· Portable and Technology independent
· VHDL is not case sensitive
· VHDL is a free form language. You can write the whole program on a single line.


[image: ]
Fig: One Sample Program in VHDL.

Quartus II:

Starting New Project:
· Open Quartus II 
· Start Wizard File->New Project Wizard
· Click Next , Specify Name of Project and the directory and click Next
· Specify files you want to add and click Next
· Specify FPGA and click Next , Next and Finish
Cyclone II , EP2C20F484C6

Conclusion:


Practical 5										Date:

Aim: Implementation of basic logic gates and its testing.

Objective: 
1. First Exposure to VHDL Coding.
2. To Implement the VHDL coding of basic gates.

VHDL Code:


Result:




































Conclusion:



Practical 6										Date:

Aim: Implementation of Adder Circuit and its testing.

Objective: 
1. To Implement VHDL Code for Half Adder.
2. To Implement the VHDL Code for Full Adder.

VHDL Code:
1. VHDL Code for Half Adder








Result:




















2. VHDL Code for Full Adder.




















Result:















Conclusion:




Practical 7										Date:

Aim: Implementation of D Flip Flop and its Testing.


VHDL Code:



Result:




































Conclusion:



Practical 8										Date:

Aim: Implementation of RS and JK Flip Flop and its Testing.


VHDL Code:



Result:




































Conclusion:




Practical 9										Date:

Aim: Implementation of 4:1 Multiplexer and its Testing.


VHDL Code:



Result:




































Conclusion:




Practical 10										Date:

Aim: Implementation of 3 to 8 Decoder and its Testing.


VHDL Code:



Result:




































Conclusion:




Practical 11										Date:

Aim: Implementation of BCD Counter and its Testing.


VHDL Code:



Result:




































Conclusion:




Practical 12										Date:

Aim: Design of Logic Gates using Block Diagram Technique and its Testing.


Circuit Schematic:



Result:




































Conclusion:




Practical 13										Date:

Aim: Design of Adder Circuit using Block Diagram Technique and its Testing.


Circuit Schematic:



Result:




































Conclusion:




Practical 14										Date:

Aim: Implement one FSM that has two state, namely stateA and stateB. There are three input variables x, y, d and q as output variable.When d=0 the current state is hold otherwise state has to be changed to other state. Reset state is stateA. Here stateA means q=x and stateB means q=y.


VHDL Code:
[Note: This Practical is not compulsory those who have done paste code here, otherwise they may skip this by deleting practical 14 from]


Result:




































Conclusion:



Appendix A
Microwind Reference Guide

FILE MENU


		
	 		
VIEW MENU





SIMULATE MENU



	





ANALYSIS MENU















PALETTE ()

[image: ]



LIST OF ICONS 
											


		Open a layout file MSK

		Save the layout file in MSK format

		Draw a box using the selected layer of the palette	

		Delete boxes or text.

		Copy boxes or text

		Stretch or move elements

		Zoom In

		Zoom Out

		View all the drawing


		Extract and view the electrical node pointed by the cursor

		Extract and simulate the circuit

		Measure the distance in lambda and micron between two points

		2D vertical aspect of the device		

		Design rule checking of the circuit. Errors are notified in the layout.	

		Add a text to the layout. The text may include simulation properties.

		Chip library of contacts, MOS, metal path, 2-metal routing, pads, etc...

		View the palette

		Static MOS characteristics

LIST OF FILES 

		
	PROGRAM			DESCRIPTION					
	MICROWIND.EXE		Layout Editor and Simulator		
	*.RUL				Design rule files
	*.MSK				Layout files
	*.MES				MOS I/V Measurements
	*.CIR				Spice compatible files
	*.TXT				Verilog text inputs

*.RUL	The MICROWIND program reads the rule file to update the simulator parameters (Vt, K,VDD, etc...), the design rules and parasitic capacitor values. A detailed description of the .RUL file is reported at the end of Chapter 8. 

*.MSK	The MICROWIND software creates data files with the appendix .MSK. Those files are simple text files containing the list of boxes and layers, and the list of text declarations. The 3D module can simulate the fabrication process of any .MSK file. 

*.CIR	The MICROWIND program generates a SPICE compatible description file when the command File -> Make SPICE File is invoked. For example, if the current file is MYTEST.MSK, a text file MYTEST.CIR is generated and contains the list of transistors, capacitors and voltage sources corresponding to the drawing, in SPICE compatible format



Appendix B
Introduction Quartus II
      It is useful for ,
· Synthesis tool 
· Place and Route
· Simulator
· Debugger
· Programmer
· And much more

Project Files Description

· .qpf Project file
· .qsf Settings file (timing , constrains , pin)
· .vhd Design file , must be at least a top level design file  its ports are directly connected to physical pins
· .stp Signal Tap file
· .vwf Simulation Waveform file
· .sof FPGA programming file

Starting New Project
Open Quartus II (7.2)
Start Wizard File->New Project Wizard
Click Next , Specify Name of Project and the directory and click Next
Specify files you want to add and click Next
Specify FPGA and click Next , Next and Finish
Cyclone II , EP2C20F484C6

Create VHDL File
· Create new files File->New
· Add existing files and set compilation order Assignments ->Settings->Files
· Changing Top level entity 
Assignments->General ->Top-level entity
· Analyze the project :  Push         Button
· View resource utilization at “Compilation Report”
Simulation
· Add Vector file File->New



· Add signals Edit->Insert->Insert node or bus
· Press the “Node Finder” and select signals 
· Change Simulation Time Edit->End Time, Edit->Grid Size

[image: ]
Setting waveforms
· Use the buttons on the left side to generate input signals
[image: ]

Running simulation
· Save the Waveform file and go to : 
-> Processing ->Simulator tools
· Set simulation mode to Functional and choose your file as simulation input
· Generate Netlist > start simulation > Report

[image: ]
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